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1 Overview

This book serves as a guide for those interested in using IBM SPSS Statistics software to assist in statistical
data analysis—whether as a companion to a statistics or research methods course, a stand-alone guide for a
particular project, or an aid to individual learning. The images and directions used in this book come from
IBM SPSS Statistics Version 22.0, first released in August 2013. If you are using IBM SPSS Statistics
Version 21, you will notice considerable consistency. For anyone using SPSS Version 20 or 19, or even
PASW Statistics 18 or earlier, there will be a great deal of consistency with these instructions and images,
although there will be some areas where there are differences due to the upgrades in the SPSS Statistics
Version 22 software. So, the older your version of SPSS Statistics (or PASW Statistics), the more likely you
will see some differences in methods, availability of options, screen views, and output format.

What’s the Difference Between SPSS Statistics and PASW Statistics?

None.

There is essentially no difference. The program formerly known simply as “SPSS” became “SPSS Statistics”
with the Version 17.0 release, and then “PASW Statistics” with the Version 18.0 release. After SPSS, Inc.,
became an IBM company in October 2009, the branding going forward was changed so that future releases of
the software (Version 19.0 and beyond) are known as “IBM SPSS Statistics.” When SPSS was originally
developed, it stood for Statistical Package in the Social Sciences. The motivation for the PASW (Predictive
Analytics Software) branding change was to reflect the considerable reach of the software to more business-
oriented realms, although this name is used only for Version 18.

Statistical Software

The SPSS/PASW Statistics software works with several kinds of computer files: data files, output files, and
syntax files. Data files are those computer files that contain the information the user intends to analyze.
Output files contain the statistical analysis of these data, often displayed as tables, graphs, and/or charts.
Syntax files are computer instructions that tell the SPSS Statistics software what to do. Syntax files are not
used with the student version of SPSS Statistics and are dealt with as an advanced application in Chapter 12
of this book. IBM discontinued the student version of SPSS software for Version 19 (PASW was the last
version for which a limited student version was available) and has not released any information about a
student version for Version 22 as of this writing.

The General Social Survey (GSS) serves as the secondary data set used throughout this book to demonstrate
typical functions of the statistical software by example. IBM SPSS Statistics is the software program,
produced by SPSS, an IBM company as of 2009, based in Chicago, Illinois. The GSS is a data set that is read
and analyzed by the SPSS Statistics software; it is a data file containing the information to be analyzed. The
two things are distinct and can be used in separate contexts without the other, although the GSS data file used
for this book, and available on the companion website, is an SPSS data file and cannot be read without
opening it in SPSS Statistics or converting it to another file format suitable for use in another program.



5/29/17, 3*02 PM

Page 2 of 12https://jigsaw.vitalsource.com/api/v0/books/9781506331744/print?from=1&to=14

About the GSS Data

The National Opinion Research Center (NORC) at the University of Chicago administers the GSS. The GSS
was started in 1972 and continues today. The data used for the examples in this book come from the latest
available completed version of the GSS, collected in 2012. According to NORC, with the exception of the
U.S. census, the GSS is the most frequently analyzed source of information in the social sciences. NORC
acknowledges that there are at least 14,000 instances in which the GSS has been used for articles in scholarly
journals, books, and doctoral dissertations. Furthermore, it is estimated that more than 400,000 students
annually use the GSS in their work.

The GSS contains many demographic and attitudinal questions, as well as rotating topics of special interest.
A number of core questions have remained unchanged in each survey since 1972. This allows rich
longitudinal research about attitudes, opinions, and demographics in the United States. Topical questions
appear sometimes for just 1 year; other times, they can appear for a period of years. Therefore, the GSS is
versatile as a longitudinal data resource and a relevant cross-sectional resource.

To maximize the amount of information that can be collected in this massive interviewing project, the GSS
uses a split ballot design, in which NORC asks some questions in only a random subsample of the
households and asks other questions in other households. Some questions, including demographic items, were
asked of all respondents. When we begin analyzing the GSS data, you will notice that some data items have
substantial numbers of respondents for whom data are marked as missing. For the most part, this refers to
respondents who were not asked those particular questions as a result of the split ballot design.

Although many items were asked of only subsamples of respondents, you can still take the responses as
representative of the U.S. adult noninstitutionalized population, subject to normal sampling error. For more
information about how the GSS data were collected, see Appendix B, “Field Work and Interviewer
Specifications,” and Appendix C, “General Coding Instructions,” in General Social Surveys: 1972–2012:

Cumulative Codebook (Smith, Marsden, Hout, & Kim, 2013).

SPSS/PASW Electronic Files

IBM SPSS Statistics 23 (as well as other versions of SPSS/PASW Statistics) uses different file extensions, or
endings, and associated icons to signify types of files. For instance, a file named “file.sav” is a data file called
“file.” The .sav extension is used to signify that it is a data file. Again, data files contain the information
SPSS/PASW Statistics analyzes. A file with the extension .sps is an SPSS Statistics syntax file, and a file with
the extension .spv (or .spo for versions of SPSS software prior to Version 17.0) is an SPSS Statistics output
file. Output files contain analyses of data, such as charts, tables, and other statistical and data manipulation
information. Syntax files contain coded instructions for SPSS Statistics to perform operations on data and
produce output. It is not necessary to create, save, or even deal with syntax files for most basic SPSS
Statistics functions; therefore, syntax files will be covered only to the level of description and simple use in
Chapter 12.

Opening Existing Data Files

When first opening the SPSS Statistics 23 application, you will be presented with a window, like the one
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below, that offers options for how to begin your SPSS session. On the lower left side, you’ll see a box labeled
“Recent Files.” You will be able to instantly click and begin working with one of those files. If you do not see
the file you need, you can click the folder at the bottom of the list, “Open another file . . .” which will allow
you to locate your file. Sometimes, however, this window doesn’t appear; you can see that there’s a check
box that will prevent it from appearing when SPSS Statistics is reopened. (To “uncheck” the box and make it
so the window will open each time the SPSS Statistics application is launched, visit the “Options” menu,
described later in this chapter.)

Otherwise, to open an SPSS Statistics data file that you already have or have obtained, select the “File” menu;
then choose “Open” and select “Data . . .” (For other file types, see the section on importing data from non-
SPSS file formats.) At this point, you will need to navigate the disk drives attached to your computer (or
network drives or other sorts of storage devices) to locate the data file you wish to open. Once you locate the
file, either double-click it or click it once and then click the “Open” button toward the bottom right side of the
“Open Data” dialog box.

SPSS Statistics will then open the data file, and you will be presented with the information in a grid format
(somewhat similar to a Microsoft Excel or other spreadsheet environment). You have choices about both the
way the information is presented and the information you see. For example, you can choose to see the Data
View, presented in the following image. Here, you are viewing the actual data. Note that the variables are
listed in columns, with each case recorded as a row. The variable “age” has been selected as a reference point.
The data in that column tell the age of each of the respondents.
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Now, click the “Variable View” tab, which is located toward the bottom left of the screen. (Note that the
“Data View” tab is currently selected; this is the default when opening a new file with SPSS [or PASW]
Statistics 17 or newer.) Although the information looks somewhat different, you are still looking at the same
data file. See the following image:

Again, the “age” variable has been selected for reference. In this view, variables are depicted in rows, with
each row showing information about a single variable, such as variable label, category label, type, level of
measurement, and so forth. You can add to, edit, or delete any of the variable information contained in this
view by directly typing into the cells. This view does not show the actual response data; to view those data,
you would need to select the “Data View” tab.

Importing Data From Statistics File Formats Other Than SPSS or

PASW

There is often a need to analyze existing data files that were not created or formatted by SPSS Statistics
software. These files might be created by other statistical software packages (e.g., SAS or Stata) or by other
types of numeric operational programs (e.g., Microsoft Excel). To open an Excel file, for example, first select
the same menu options you would if you were opening an SPSS/PASW Statistics data file:

File → Open → Data . . .
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Now, at the “Files of type” prompt at the bottom of the dialog box, click the arrow at the right to expand the
choices. Next, select “Excel (*.xls, *.xlsx, *.xlsm).” You will need to navigate your hard drive, other drives,
or other locations to find your file. Once you locate the file, select and open it. At this point, you will be
presented with a new dialog box:

If the column headings in the Excel file contain the variable names, make sure the box labeled “Read variable
names from the first row of data” is selected. If the column headings are not formatted in a way that conforms
to the SPSS Statistics variable-naming conventions, they will be transformed into permitted variable names,
and the original names will be recorded as variable labels.

To import only a portion of the Excel file, enter the range of cells from which you would like to import data.

It is also possible to import data from databases, text files, and other sources. Follow the same instructions as
for Excel files, except for the file type you select. Depending on the file type you choose, you will be
presented with different dialog boxes or wizards to import the data and process them for use by SPSS
Statistics.

In some cases, you may simply have unlabeled data in a particular file, or the variable names or other
information may be of little or no use to you. In such a case, depending on the size of the file, you could copy
the data from the original numeric program (e.g., Microsoft Excel) and then paste them directly into the SPSS
Statistics Data View window. This is particularly useful if you just want to add numeric values from another
source and enter or program the other information using SPSS Statistics.

Opening Previously Created Output Files

To open a previously created output file, select from the “File” menu as follows:



5/29/17, 3*02 PM

Page 6 of 12https://jigsaw.vitalsource.com/api/v0/books/9781506331744/print?from=1&to=14

File → Open → Output . . .

You will be presented with the following dialog box:

Here, just navigate to find your file, as you would any other type of file. Once you locate it, select and open
the file. SPSS Statistics will open the file into an output Viewer window. There, you can view and edit it.
Note that IBM SPSS Statistics Version 23 (as well as Versions 22, 21, 20, 19, PASW Statistics 18, and SPSS
Statistics 17) uses the .spv file extension. Earlier versions of SPSS software use the .spo file extension. IBM
SPSS Statistics Version 23 is capable of opening output files created with older versions of SPSS software,
but files created in the new version cannot necessarily be opened in the older versions.

Saving Files

All types of SPSS Statistics files are saved in virtually the same way as files in any modern computer
program. Select either

File → Save to save the file with the currently assigned name

or

File → Save As . . . to save the file in a different file, with a new name.

The first option will automatically save the file without prompting you with a dialog box, unless you are
working with a new, yet unnamed file. In that case, you will get the same type of dialog box as though you
had selected the “Save As . . .” option. If you do choose the second option, you will be shown a dialog box
prompting you to name the file and to select the location on your computer or network where the file is to be
placed.

Creating New SPSS Statistics Data Files
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To create a new SPSS Statistics data file, select the “File” menu; then choose “New,” and select “Data”:

File → New → Data

You will then be presented with a blank Data Editor window like the one following:

You can immediately start entering information related to the variables you wish to create and/or the actual
data codes you may have. In the Data Editor window that follows, the Variable View tab has been selected,
and information has been entered for two variables: “age” and “sex.” Notice that the labels have been
entered: “AGE OF RESPONDENT” and “SEX OF RESPONDENT,” respectively. Other information about
the variables has been selected and entered as well.

For the “sex” variable, value labels have been entered. This was done by clicking the “Values” cell for that
variable and then selecting the button with three small dots. The following dialog box appeared:
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In the “Value Labels” box, you can enter the label for each of the category codes for the variable. In this case,
“0” was entered in the “Value” box, and “FEMALE” was entered in the “Label” box. At that point, to record
the information, it is necessary to click the “Add” button. Notice also that “1” was entered in the “Value” box,
and “MALE” was entered in the “Label” box, and again, the “Add” button was clicked. (This procedure also
produces a dummy variable called “male,” for which the value of 1 represents “male” and 0 represents “not
male.”) By doing this, we are assigning numbers to the categories of the variable “sex” so that SPSS Statistics
knows how to record whether each respondent is male or female; the software uses numbers to keep track of
those attributes. By using numbers, the software can track the categories and use that information to perform
statistical operations such as those described throughout this book.

It is also possible to enter data directly into the Data Editor. To do this, click the Data View tab at the lower
left of the Data Editor window. The columns now represent the newly created variables “age” and “sex.” You
can directly type the values for each case or row. You could also copy ( + C on a Windows PC, or + C on a
Macintosh computer) and paste ( + V on a Windows PC, or + V on a Macintosh computer) these values from
another software program, such as Microsoft Excel, if you already have them categorized by the same
variables.

Notice that the data entered (or pasted) above appear as the numeric codes that were assigned for nominal and
ordinal variables that have those assignments. There is a way to display the actual label in this window. Click
the following from the SPSS menus, and note the differences in the following screen image:

View → Value Labels
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Value labels can also be displayed prior to entering data. When you double-click the right side of a cell, an
arrow will appear. If you click the arrow, as seen in the screen image above, a pull-down menu consisting of
all of the available categories for that variable will appear: In this case, the list consists of “FEMALE” and
“MALE.” If you are entering data directly into SPSS Statistics, using this option can make data entry easier
and can help avoid errors, such as typos of values that are not within the range of categories for a variable.

Creating and Editing SPSS Statistics Output Files

Output files are created by SPSS Statistics when you instruct the software to perform functions. For example,
if you request SPSS Statistics to provide frequencies and central tendency values for three variables from
your data set, an output file will be produced automatically. The information you have requested will be
presented in the output Viewer window unless an output file is already open in the output Viewer, in which
case the new information will be appended to that file. To edit the output, you’ll select and double-click the
part you wish to work with, and there are tools to facilitate that task. More information on this topic will be
provided in Chapter 4, “Organization and Presentation of Information.”

Preferences: Getting Started

To change the settings, parameters, and preferences for the SPSS Statistics program, select the “Edit” menu
and choose “Options . . .”:

Edit → Options . . .

You will be presented with a dialog box like the one shown here:

Numerous features can be controlled using this dialog box, and most are intuitive in their operation. As a user
becomes more experienced, he or she often uses more of these features. From the start, however, most SPSS
Statistics users will want to make sure that variables will be displayed throughout the program in alphabetical
order and also by name (rather than label). This can be done by selecting the “General” tab and clicking the
radio buttons for “Display names” and “Alphabetical.”
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This is particularly important if you are using or creating a data set that contains a large number of variables,
such as the General Social Survey. Although it is clear that alphabetizing the list will facilitate easier access
to variables, listing by name is also crucial because variable labels are more detailed and may not necessarily
begin with or even use the same letters as the variable names. Changing or verifying these settings up front
can save a good deal of time and frustration. If a data set is opened and the preferences have not been set to
the desired parameters, you can still go to the “Options” dialog box and make the change while the data set is
open. (In some older versions of SPSS, it would be necessary to close the data set, make the change, and
reopen the data set.)

If you have started a procedure and don’t wish to change the program preferences as described above, you
can do it on the fly. Just right-click (or + click for a Macintosh computer with a standard one-button mouse)
one or more of the variables from the list shown in the dialog box with which you are working. You can
select “Display Variable Names” and “Sort Alphabetically.” Incidentally, you can also select “Variable
Information . . .” for any of the variables (not more than one at a time), which will provide details about
values, value labels, and so forth.

Note that this procedure, pictured above, will make the change only in the current dialog box (including
return visits to that same dialog box, “Frequencies” in this case). You will need to use the same procedure to
organize variables in other dialog boxes or make the change in the program preferences window (Edit →

Options). Also, note that this procedure does not work in all windows (e.g., Utilities → Variables; see the

next paragraph).

To get a quick overview of the variables in a given data set, SPSS Statistics has a variable utility window to
provide useful information about each of the variables in a way that can be easily navigated (and such that
information can be easily pasted to output if desired). Opening this window will demonstrate the importance
of organized naming and ordering of variables in a large data file. Choose the “Utilities” menu; then select
“Variables . . .”:

Utilities → Variables . . .
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When you select a variable from the alphabetized list of variable names on the left, information about that
particular variable will appear on the right side of the box, including the label, the level of measurement, and
the value labels. This is a fast way to determine what kinds of variables are available in your data set that are
suited to different statistical methods of analysis.

Measurement of Variables Using SPSS Statistics

Whether creating a new data file with SPSS Statistics or using an existing data file, it is important to
understand how variables have been measured, or “treated,” by the creator of the data file. This treatment is a
factor of how the data were collected—how much information is contained within the data set about each
variable.

First, it is important to be aware that SPSS Statistics can record variables as either string variables or numeric

variables. String variables can consist of letters and/or numbers and cannot be treated numerically; therefore,
string variables must be treated at the nominal level of measurement. Numeric variables use numbers to
represent response values. These numbers may represent actual numbers, ranked categories, or unranked
categories. In other words, numeric variables may be nominal, ordinal, interval, or ratio.

In social science statistics and research methods courses, variables are typically described using these four
categories. Many textbooks, such as Investigating the Social World (Schutt, 2011) and Adventures in Social

Research (Babbie, Wagner, & Zaino, 2015), elaborate all four of those categories. In some texts, interval and
ratio measures are combined, as is the case in Social Statistics for a Diverse Society (Frankfort-Nachmias &
Leon-Guerrero, 2014).

SPSS Statistics uses the following codes for levels of measurement: nominal, ordinal, and scale. You can
select the level of measurement from the pull-down menu for each variable in the “Measure” column of the
Variable View window. “Nominal” and “Ordinal” both correspond to the concepts with the same names. The
“Scale” denotation corresponds to interval-ratio, interval, and ratio. There are functions within the SPSS
Statistics software that will limit your ability to conduct analyses or create graphs on the basis of the
recognized level of measurement. Therefore, it is crucial to verify that the indicator in the “Measure” column
of the Variable View is correct for all variables you will use in your analyses.
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